Error of 5GLLSimulator with R2017a

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #13524
    EFTHIMIS
    Participant

    Dear sir
    I’m using 5GLL_Link Level_Simulator_v1.1. with matlab R2017a.I faithfully followed the instructions of the manual in order to run main.m but I face the following problems:

    The sampling rate was set to 15.120000 MHz.
    Sampling rate does not match the predefined delays of the channel model!
    Delay taps are changed according to (top = desired value; bottom = chosen value):
    1.0e-06 *

    0 0.1100 0.1900 0.4100
    0 0.1323 0.1984 0.3968

    ——- Started ——-
    Warning: The temporary variable signalLength will be cleared
    at the beginning of each iteration of the parfor loop.
    Any value assigned to it before the loop will be lost. If
    signalLength is used before it is assigned in the parfor loop,
    a runtime error will occur.
    See Parallel for Loops in MATLAB, “Temporary Variables”.
    > In main (line 44)
    Caught “std::exception” Exception message is:
    Invalid character code sequence detected.
    Error using distcomp.remoteparfor/getCompleteIntervals (line
    146)
    An unexpected error occurred during PARFOR: Error in remote
    execution of remoteParallelFunction : RUNTIME_ERROR

    Error in main (line 44)
    parfor iSweep = 1:length(simParams.simulation.sweepValue) %
    this may be ‘for’ or ‘parfor’

    as you will understand I am a beginner in matlab
    please look at it and tell me my mistake
    Thank you
    Efthimis Tomaras

    #13538

    Dear Efthimis,

    please try to change the line 44 in main.m from “parfor” to “for”. Then, run the main.m again. This should lead to a more detailed error message.

    Please report the error message when running without “parfor”.

    kind regards
    Stefan Pratschner

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.