NOMA with polar coding

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11302
    ahmetemir
    Participant

    Hi,

    I’m new on 5G link level simulator. I selected simulation scenario as NOMA on main.m. I replace the code concerned with channel coding on NOMA.m as :

    %% Channel Coding Parameters
    
    scStr.coding.code                           = {'Polar'};                                                              
    scStr.coding.decoding                       = {'SC'};                                                                     
    scStr.coding.decodingIterations             = [8];

    But MATLAB has given error as:

    Error using parallel_function (line 607)
    All workers aborted during execution of the parfor loop.
    
    Error in main (line 44)
    parfor iSweep = 1:length(simParams.simulation.sweepValue) % this may be 'for' or 'parfor'
     
    The client lost connection to worker 4. This might be due to network problems, or the interactive
    communicating job might have errored.

    My MATLAB version 2017b with parallel toolbox. I have workstation which 64 GB RAM present on it. MATLAB is able to use 12 parallel worker.

    Also I tried different decoding options and decoding iterations that Vienna 5G LL support for Polar Decoding, I always came across this error.

    How could I overcome this error and How should I use polar coding with NOMA??

    • This topic was modified 2 years, 10 months ago by ahmetemir.
    • This topic was modified 2 years, 10 months ago by ahmetemir.
    #11305

    Hi,

    for debugging, please change the ‘parfor’ loop to a simple ‘for’ loop in line 44 of main.m. Then execute your scenario again. This should lead to a more detailed error message.

    best
    Stefan

    #11317
    Bashar Tahir
    Participant

    Also, when polar coding is selected, the coding.decodingIterations field represents the list size of the decoder. This only works if you have selected the decoding algorithm to be ‘List-SC’ or ‘CRC-List-SC’. Otherwise, the ‘SC’ algorithm will just run the list decoder with a list size of 1 by default. In other words, if you want to see the effect of the list size, you need to set coding.decoding to ‘List-SC’ or ‘CRC-List-SC’.

    Best,
    Bashar

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.