PL model

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7472
    Darren
    Participant

    Dear Moderators,

    After having run a simulation, is it posible to know which PL model was ultimately used? I know there are three, the LOS, NLOS and O-to-I, but I don’t know which is used for my simulations. Thank you

    Kinda regards,
    Darren

    #7518

    Dear Darren,

    Our simulator supports different types of path loss models. To set which path loss model you want to use, you can do that in the config file that you use: +simulation_config/xxx.m

    – After running the simulation you can check the property macroscopic_pathloss_model saved for each eNodeB_sector, it shows the name of the pathloss and the environment used.

    – Specifically for the 3D channel model, with the path loss generation also specific LOS/NLOS/OTOI pathloss is generated. For more details please check the documentation where it explains the 3D model features.

    If you have any further question, please let us know!

    Best regards,
    Fjolla

    #7539
    Darren
    Participant

    Dear Fjolla,

    Thank you for your response!
    Regarding the 3D model: Is it possible to use the NLOS pathloss only, or are the three of them always generated regardless of the situation? If it is possible, how is that done?

    Best regards,
    Oscar

    #7549

    Dear Oscar,

    Yes it is possible to simulate only NLOS case, you just have to set LOS map to zeros, and not use the LOS probability given by the model.

    This can be done in +macroscopic_pathloss_model/generalPathlossModel.m by modifying the parameter LOS_positions.

    Best regards,
    Fjolla

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.