Predefined RRH and their antennas

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #6094
    Naser
    Participant

    Dear Martin,

    When I add RRH (predefined) it only work when there is single omnidirectional eNodeB, otherwise this error appear:

    i want to add single RRH per eNodeB in tri sector site ==> 3 RHHs per 3 EnodeBs.

    I used:
    simulation_type = ‘tri_sector_tilted’;
    simSet = [4 2 4];

    LTE_config.RRHs_enabled = true;
    LTE_config.RRH.nTX = 2; %==> % only one RRH per eNodeB.
    LTE_config.RRH.antenna_type = ‘omnidirectional’;
    LTE_config.RRH.distribution_type = ‘predefined’;
    LTE_config.RRH.distribution_params.RRH_positions= [150,150;-150,150;150,-150];
    LTE_config.RRH.distribution_params.RRH_azimuths = [0;0;0];

    this error appear:
    Index exceeds matrix dimensions.
    Error in network_generation.RRH.predefined_distribution (line 10)
    for rrh_=1:size(RRH_positions(:,:,b_),1)
    Error in network_generation.add_RRHs (line 13)
    network_generation.RRH.predefined_distribution(RRH_config,eNodeBs);
    Error in LTE_init_network_generation (line 96)
    network_generation.add_RRHs(LTE_config,eNodeBs,networkPathlossMap );
    Error in LTE_sim_main (line 39)
    [sites, eNodeBs, networkPathlossMap, networkShadowFadingMap LTE_config] =
    LTE_init_network_generation(LTE_config,varargin);

    2- when i try to setup RRH antenna to any other +antenna, such as ‘berger’, the following error appear:

    Reference to non-existent field ‘antenna’.
    Error in antennas.antenna.attach_antenna_to_eNodeB (line 24)
    an_eNodeB.antenna = antennas.bergerAntenna(LTE_config.antenna.max_antenna_gain);
    Error in network_generation.RRH.predefined_distribution (line 22)
    antennas.antenna.attach_antenna_to_eNodeB(eNodeBs(b_).RRHs(rrh_),RRH_config);
    Error in network_generation.add_RRHs (line 13)
    network_generation.RRH.predefined_distribution(RRH_config,eNodeBs);

    Error in LTE_init_network_generation (line 96)
    network_generation.add_RRHs(LTE_config,eNodeBs,networkPathlossMap );

    Error in LTE_sim_main (line 39)
    [sites, eNodeBs, networkPathlossMap, networkShadowFadingMap LTE_config] =
    LTE_init_network_generation(LTE_config,varargin);

    Thanks,
    Naser

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.